#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ix)(?(DEFINE)" & @CRLF & _
" (?'loc_part' [\w!#$%&'*+\-\/=?^`{|}~]+ )" & @CRLF & _
" (?'loc' \g'loc_part' (?: \. \g'loc_part' )* )" & @CRLF & _
" (?'subdom' [a-z] (?: [a-z\d-]* [a-z\d] )? )" & @CRLF & _
" (?'tld' [a-z]{2,6} )" & @CRLF & _
")" & @CRLF & _
"(?'local' \g'loc' ) @ (?'domain' (?: \g'subdom' \. )+ \g'tld' )"
Local $sString = "this is an email: this.is.an-example@example.com" & @CRLF & _
"" & @CRLF & _
"how about a.b.c+194829@example.org?" & @CRLF & _
"not totallynotanemail@@exampl.e" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")