package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?(DEFINE)
(?'loc_part' [\w!#$%&'*+\-\/=?^`{|}~]+ )
(?'loc' \g'loc_part' (?: \. \g'loc_part' )* )
(?'subdom' [a-z] (?: [a-z\d-]* [a-z\d] )? )
(?'tld' [a-z]{2,6} )
)
(?'local' \g'loc' ) @ (?'domain' (?: \g'subdom' \. )+ \g'tld' )`)
var str = `this is an email: this.is.an-example@example.com
how about a.b.c+194829@example.org?
not totallynotanemail@@exampl.e
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}