using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)
(?'loc_part' [\w!#$%&'*+\-\/=?^`{|}~]+ )
(?'loc' \g'loc_part' (?: \. \g'loc_part' )* )
(?'subdom' [a-z] (?: [a-z\d-]* [a-z\d] )? )
(?'tld' [a-z]{2,6} )
)
(?'local' \g'loc' ) @ (?'domain' (?: \g'subdom' \. )+ \g'tld' )";
string input = @"this is an email: this.is.an-example@example.com
how about a.b.c+194829@example.org?
not totallynotanemail@@exampl.e
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}