import Foundation
let pattern = #"Game\.of\.Thrones\.S08\.(1080p|720p).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Game.of.Thrones.S06.720p.BluRay.x264-DEMAND
Game.of.Thrones.S06.1080p.BluRay.x264-DEMAND
Game.of.Thrones.S08.720p.BluRay.x264-DEMAND
Game.of.Thrones.S08.1080p.BluRay.x264-DEMAND
Game.of.Thrones.S08.MiX.XviD-VARGRP
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}