const regex = /Game\.of\.Thrones\.S08\.(1080p|720p).*/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Game\\.of\\.Thrones\\.S08\\.(1080p|720p).*', 'i')
const str = `Game.of.Thrones.S06.720p.BluRay.x264-DEMAND
Game.of.Thrones.S06.1080p.BluRay.x264-DEMAND
Game.of.Thrones.S08.720p.BluRay.x264-DEMAND
Game.of.Thrones.S08.1080p.BluRay.x264-DEMAND
Game.of.Thrones.S08.MiX.XviD-VARGRP`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}