re = /Game\.of\.Thrones\.S08\.(1080p|720p).*/i
str = 'Game.of.Thrones.S06.720p.BluRay.x264-DEMAND
Game.of.Thrones.S06.1080p.BluRay.x264-DEMAND
Game.of.Thrones.S08.720p.BluRay.x264-DEMAND
Game.of.Thrones.S08.1080p.BluRay.x264-DEMAND
Game.of.Thrones.S08.MiX.XviD-VARGRP'
# Print the match result
str.match(re) do |match|
puts match.to_s
end