import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Game\\.of\\.Thrones\\.S08\\.(1080p|720p).*";
final String string = "Game.of.Thrones.S06.720p.BluRay.x264-DEMAND\n"
+ "Game.of.Thrones.S06.1080p.BluRay.x264-DEMAND\n"
+ "Game.of.Thrones.S08.720p.BluRay.x264-DEMAND\n"
+ "Game.of.Thrones.S08.1080p.BluRay.x264-DEMAND\n"
+ "Game.of.Thrones.S08.MiX.XviD-VARGRP";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}