using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Game\.of\.Thrones\.S08\.(1080p|720p).*";
string input = @"Game.of.Thrones.S06.720p.BluRay.x264-DEMAND
Game.of.Thrones.S06.1080p.BluRay.x264-DEMAND
Game.of.Thrones.S08.720p.BluRay.x264-DEMAND
Game.of.Thrones.S08.1080p.BluRay.x264-DEMAND
Game.of.Thrones.S08.MiX.XviD-VARGRP";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}