package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)Game\.of\.Thrones\.S08\.(1080p|720p).*`)
var str = `Game.of.Thrones.S06.720p.BluRay.x264-DEMAND
Game.of.Thrones.S06.1080p.BluRay.x264-DEMAND
Game.of.Thrones.S08.720p.BluRay.x264-DEMAND
Game.of.Thrones.S08.1080p.BluRay.x264-DEMAND
Game.of.Thrones.S08.MiX.XviD-VARGRP`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}