re = /<if (?'name'\w+)(?'op'[=!<>][=]?)(?'value'.+?)>(?'true'.+?)(?:<else>(?'false'.*))?<\/if>/
str = '<if varName==TRUE>This will be printed if true
<else>Otherwise this will be printed if false
</if>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end