using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<if (?'name'\w+)(?'op'[=!<>][=]?)(?'value'.+?)>(?'true'.+?)(?:<else>(?'false'.*))?<\/if>";
string input = @"<if varName==TRUE>This will be printed if true
<else>Otherwise this will be printed if false
</if>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}