package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<if (?'name'\w+)(?'op'[=!<>][=]?)(?'value'.+?)>(?'true'.+?)(?:<else>(?'false'.*))?<\/if>`)
var str = `<if varName==TRUE>This will be printed if true
<else>Otherwise this will be printed if false
</if>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}