$re = '/<if (?\'name\'\w+)(?\'op\'[=!<>][=]?)(?\'value\'.+?)>(?\'true\'.+?)(?:<else>(?\'false\'.*))?<\/if>/s';
$str = '<if varName==TRUE>This will be printed if true
<else>Otherwise this will be printed if false
</if>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);