import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<if (?'name'\\w+)(?'op'[=!<>][=]?)(?'value'.+?)>(?'true'.+?)(?:<else>(?'false'.*))?<\\/if>";
final String string = "<if varName==TRUE>This will be printed if true\n"
+ "<else>Otherwise this will be printed if false\n"
+ "</if>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}