const regex = /<if (?'name'\w+)(?'op'[=!<>][=]?)(?'value'.+?)>(?'true'.+?)(?:<else>(?'false'.*))?<\/if>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<if (?\'name\'\\w+)(?\'op\'[=!<>][=]?)(?\'value\'.+?)>(?\'true\'.+?)(?:<else>(?\'false\'.*))?<\\\/if>', 'gs')
const str = `<if varName==TRUE>This will be printed if true
<else>Otherwise this will be printed if false
</if>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}