import Foundation
let pattern = #"(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"1 2013-07-25 11599" CLOSED
"2 2013-07-25 256" PENDING_PAYMENT
"3 2013-07-25 12111" COMPLETE
"4 2013-07-25 8827" CLOSED
"5 2013-07-25 11318" COMPLETE
"6 2013-07-25 7130" COMPLETE
"7 2013-07-25 4530" COMPLETE
"8 2013-07-25 2911" PROCESSING
"9 2013-07-25 5657" PENDING_PAYMENT
"10 2013-07-25 5648" PENDING_PAYMENT
"11 2013-07-25 918" PAYMENT_REVIEW
"12 2013-07-25 1837" CLOSED
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)