# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w+)"
test_str = ("\"1 2013-07-25 11599\" CLOSED\n"
"\"2 2013-07-25 256\" PENDING_PAYMENT\n"
"\"3 2013-07-25 12111\" COMPLETE\n"
"\"4 2013-07-25 8827\" CLOSED\n"
"\"5 2013-07-25 11318\" COMPLETE\n"
"\"6 2013-07-25 7130\" COMPLETE\n"
"\"7 2013-07-25 4530\" COMPLETE\n"
"\"8 2013-07-25 2911\" PROCESSING\n"
"\"9 2013-07-25 5657\" PENDING_PAYMENT\n"
"\"10 2013-07-25 5648\" PENDING_PAYMENT\n"
"\"11 2013-07-25 918\" PAYMENT_REVIEW\n"
"\"12 2013-07-25 1837\" CLOSED\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.