use strict;
my $str = '"1 2013-07-25 11599" CLOSED
"2 2013-07-25 256" PENDING_PAYMENT
"3 2013-07-25 12111" COMPLETE
"4 2013-07-25 8827" CLOSED
"5 2013-07-25 11318" COMPLETE
"6 2013-07-25 7130" COMPLETE
"7 2013-07-25 4530" COMPLETE
"8 2013-07-25 2911" PROCESSING
"9 2013-07-25 5657" PENDING_PAYMENT
"10 2013-07-25 5648" PENDING_PAYMENT
"11 2013-07-25 918" PAYMENT_REVIEW
"12 2013-07-25 1837" CLOSED
';
my $regex = qr/(\w+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}