import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)";
final String string = "\"1 2013-07-25 11599\" CLOSED\n"
+ "\"2 2013-07-25 256\" PENDING_PAYMENT\n"
+ "\"3 2013-07-25 12111\" COMPLETE\n"
+ "\"4 2013-07-25 8827\" CLOSED\n"
+ "\"5 2013-07-25 11318\" COMPLETE\n"
+ "\"6 2013-07-25 7130\" COMPLETE\n"
+ "\"7 2013-07-25 4530\" COMPLETE\n"
+ "\"8 2013-07-25 2911\" PROCESSING\n"
+ "\"9 2013-07-25 5657\" PENDING_PAYMENT\n"
+ "\"10 2013-07-25 5648\" PENDING_PAYMENT\n"
+ "\"11 2013-07-25 918\" PAYMENT_REVIEW\n"
+ "\"12 2013-07-25 1837\" CLOSED\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}