#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\w+)"
Local $sString = ""1 2013-07-25 11599" CLOSED" & @CRLF & _
""2 2013-07-25 256" PENDING_PAYMENT" & @CRLF & _
""3 2013-07-25 12111" COMPLETE" & @CRLF & _
""4 2013-07-25 8827" CLOSED" & @CRLF & _
""5 2013-07-25 11318" COMPLETE" & @CRLF & _
""6 2013-07-25 7130" COMPLETE" & @CRLF & _
""7 2013-07-25 4530" COMPLETE" & @CRLF & _
""8 2013-07-25 2911" PROCESSING" & @CRLF & _
""9 2013-07-25 5657" PENDING_PAYMENT" & @CRLF & _
""10 2013-07-25 5648" PENDING_PAYMENT" & @CRLF & _
""11 2013-07-25 918" PAYMENT_REVIEW" & @CRLF & _
""12 2013-07-25 1837" CLOSED" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")