const regex = /(\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)', 'g')
const str = `"1 2013-07-25 11599" CLOSED
"2 2013-07-25 256" PENDING_PAYMENT
"3 2013-07-25 12111" COMPLETE
"4 2013-07-25 8827" CLOSED
"5 2013-07-25 11318" COMPLETE
"6 2013-07-25 7130" COMPLETE
"7 2013-07-25 4530" COMPLETE
"8 2013-07-25 2911" PROCESSING
"9 2013-07-25 5657" PENDING_PAYMENT
"10 2013-07-25 5648" PENDING_PAYMENT
"11 2013-07-25 918" PAYMENT_REVIEW
"12 2013-07-25 1837" CLOSED
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}