# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img.*?src=\"([^\"]+)\".*?>"
test_str = "<img src=\"http://192.168.1.200/wpdev/wp-content/uploads/2017/12/63725-toxic-sign-300x300.png\" alt=\"\" width=\"25\" height=\"25\" class=\"alignnone size-medium wp-image-5\" /><img alt=\"\" src=\"http://192.168.1.200/wpdev/wp-content/uploads/2017/12/pre-loader.gif\" width=\"25\" height=\"25\" class=\"alignnone size-full wp-image-4\" /> <i class=\"fa fa-motorcycle\"></i> Kawasaki"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.