import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img.*?src=\"([^\"]+)\".*?>";
final String string = "<img src=\"http://192.168.1.200/wpdev/wp-content/uploads/2017/12/63725-toxic-sign-300x300.png\" alt=\"\" width=\"25\" height=\"25\" class=\"alignnone size-medium wp-image-5\" /><img alt=\"\" src=\"http://192.168.1.200/wpdev/wp-content/uploads/2017/12/pre-loader.gif\" width=\"25\" height=\"25\" class=\"alignnone size-full wp-image-4\" /> <i class=\"fa fa-motorcycle\"></i> Kawasaki";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}