const regex = /<img.*?src="([^"]+)".*?>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img.*?src="([^"]+)".*?>', 'g')
const str = `<img src="http://192.168.1.200/wpdev/wp-content/uploads/2017/12/63725-toxic-sign-300x300.png" alt="" width="25" height="25" class="alignnone size-medium wp-image-5" /><img alt="" src="http://192.168.1.200/wpdev/wp-content/uploads/2017/12/pre-loader.gif" width="25" height="25" class="alignnone size-full wp-image-4" /> <i class="fa fa-motorcycle"></i> Kawasaki`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}