use strict;
my $str = '<img src="http://192.168.1.200/wpdev/wp-content/uploads/2017/12/63725-toxic-sign-300x300.png" alt="" width="25" height="25" class="alignnone size-medium wp-image-5" /><img alt="" src="http://192.168.1.200/wpdev/wp-content/uploads/2017/12/pre-loader.gif" width="25" height="25" class="alignnone size-full wp-image-4" /> <i class="fa fa-motorcycle"></i> Kawasaki';
my $regex = qr/<img.*?src="([^"]+)".*?>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}