// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b(?:(?:[a-f\d]{2})(?:[:-]|)){6}\b").unwrap();
let string = "This is an example of a MAC address, for example 8C:C1:21:A2:44:A3 being embedded in a text...
DE-AD-BE-EF-00-02
12:34:56:78:9A:BC
AA:BB:CC:DD:EE:FF
DE:AD:BE:EF:00:01
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}