#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b(?:(?:[a-f\d]{2})(?:[:-]|)){6}\b"
Local $sString = "This is an example of a MAC address, for example 8C:C1:21:A2:44:A3 being embedded in a text..." & @CRLF & _
"" & @CRLF & _
"DE-AD-BE-EF-00-02" & @CRLF & _
"12:34:56:78:9A:BC" & @CRLF & _
"AA:BB:CC:DD:EE:FF" & @CRLF & _
"DE:AD:BE:EF:00:01" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")