use strict;
my $str = 'This is an example of a MAC address, for example 8C:C1:21:A2:44:A3 being embedded in a text...
DE-AD-BE-EF-00-02
12:34:56:78:9A:BC
AA:BB:CC:DD:EE:FF
DE:AD:BE:EF:00:01
';
my $regex = qr/\b(?:(?:[a-f\d]{2})(?:[:-]|)){6}\b/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}