const regex = new RegExp('\\b(?:(?:[a-f\\d]{2})(?:[:-]|)){6}\\b', 'ig')
const str = `This is an example of a MAC address, for example 8C:C1:21:A2:44:A3 being embedded in a text...
DE-AD-BE-EF-00-02
12:34:56:78:9A:BC
AA:BB:CC:DD:EE:FF
DE:AD:BE:EF:00:01
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}