using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:(?:[a-f\d]{2})(?:[:-]|)){6}\b";
string input = @"This is an example of a MAC address, for example 8C:C1:21:A2:44:A3 being embedded in a text...
DE-AD-BE-EF-00-02
12:34:56:78:9A:BC
AA:BB:CC:DD:EE:FF
DE:AD:BE:EF:00:01
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}