re = /\b(?:(?:[a-f\d]{2})(?:[:-]|)){6}\b/i
str = 'This is an example of a MAC address, for example 8C:C1:21:A2:44:A3 being embedded in a text...
DE-AD-BE-EF-00-02
12:34:56:78:9A:BC
AA:BB:CC:DD:EE:FF
DE:AD:BE:EF:00:01
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end