import Foundation
let pattern = #"(?<=\[)[^\]]+(?=\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"I much prefer [kraken shell] to [fight through the pain] but [chain frost] is my favourite not a fan of []"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)