re = /(?<=\[)[^\]]+(?=\])/mi
str = 'I much prefer [kraken shell] to [fight through the pain] but [chain frost] is my favourite not a fan of []'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result