#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(?<=\[)[^\]]+(?=\])"
Local $sString = "I much prefer [kraken shell] to [fight through the pain] but [chain frost] is my favourite not a fan of []"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)