const regex = /(?<=\[)[^\]]+(?=\])/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\[)[^\\]]+(?=\\])', 'gmi')
const str = `I much prefer [kraken shell] to [fight through the pain] but [chain frost] is my favourite not a fan of []`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);