use strict;
my $str = 'I much prefer [kraken shell] to [fight through the pain] but [chain frost] is my favourite not a fan of []';
my $regex = qr/(?<=\[)[^\]]+(?=\])/mip;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";