# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\[)[^\]]+(?=\])/$1/gmi;t' <<< "I much prefer [kraken shell] to [fight through the pain] but [chain frost] is my favourite not a fan of []"