// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(ontologies\.version is.*|Application Displayable Version:.*)").unwrap();
let string = "The value found for ontologies.version is : 0.1.1822.v20150903-1030
Application Displayable Version: CI-1.1.32-1652";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}