import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(ontologies\\.version is.*|Application Displayable Version:.*)";
final String string = "The value found for ontologies.version is : 0.1.1822.v20150903-1030\n"
+ "Application Displayable Version: CI-1.1.32-1652";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}