use strict;
my $str = 'The value found for ontologies.version is : 0.1.1822.v20150903-1030
Application Displayable Version: CI-1.1.32-1652';
my $regex = qr/(ontologies\.version is.*|Application Displayable Version:.*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}