const regex = /(ontologies\.version is.*|Application Displayable Version:.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ontologies\\.version is.*|Application Displayable Version:.*)', 'g')
const str = `The value found for ontologies.version is : 0.1.1822.v20150903-1030
Application Displayable Version: CI-1.1.32-1652`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}