import Foundation
let pattern = #"(?:\s|\r)+GO\s*(?:\r|\n)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1111111
GO
222222222
GO
3333333333
GO
444444444444444
GO
55555555555555
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)