using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s|\r)+GO\s*(?:\r|\n)";
string input = @"1111111
GO
222222222
GO
3333333333
GO
444444444444444
GO
55555555555555";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}