// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:\s|\r)+GO\s*(?:\r|\n)").unwrap();
let string = "1111111
GO
222222222
GO
3333333333
GO
444444444444444
GO
55555555555555";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}