#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\s|\r)+GO\s*(?:\r|\n)"
Local $sString = "1111111" & @CRLF & _
"" & @CRLF & _
"GO" & @CRLF & _
"" & @CRLF & _
"222222222" & @CRLF & _
"GO" & @CRLF & _
"3333333333" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" GO " & @CRLF & _
"" & @CRLF & _
"444444444444444" & @CRLF & _
" GO " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"55555555555555"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")