import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s|\\r)+GO\\s*(?:\\r|\\n)";
final String string = "1111111\n\n"
+ "GO\n\n"
+ "222222222\n"
+ "GO\n"
+ "3333333333\n\n\n"
+ " GO \n\n"
+ "444444444444444\n"
+ " GO \n\n"
+ " \n\n"
+ "55555555555555";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}