$re = '/(?:\s|\r)+GO\s*(?:\r|\n)/';
$str = '1111111
GO
222222222
GO
3333333333
GO
444444444444444
GO
55555555555555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);