re = /"([^"]+)":["]*([^,^}^"]+)/i
str = '[{"name":"Піксель ТВ","url":"http://st.it-tv.org:4575/?224.1.16.33","type":81,"tsOn":false}]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end