const regex = /"([^"]+)":["]*([^,^}^"]+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"([^"]+)":["]*([^,^}^"]+)', 'gi')
const str = `[{"name":"Піксель ТВ","url":"http://st.it-tv.org:4575/?224.1.16.33","type":81,"tsOn":false}]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}