package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)"([^"]+)":["]*([^,^}^"]+)`)
var str = `[{"name":"Піксель ТВ","url":"http://st.it-tv.org:4575/?224.1.16.33","type":81,"tsOn":false}]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}